Views

General Information

Views in theWord are rectangular areas within the main window that serve a particular function within the program.  For instance, the Bible View functions to display the texts of Bibles, etc.  The Views can be manipulated very easily within theWord.

Available Views

There are five Views used by theWord.  Each of them is color-coded to aid in reference.  Each View serves a particular purpose within theWord.  See the chart below for the color codes and purposes of the respective Views.

View

Color Code

Purpose

Bible View

Blue

To view Bibles' texts

Bible Search View

Green

To search Bibles' texts

Book View

Orange

To view non-Bible resources and/or create/edit user modules

Book Search View

Purple

To search all non-Bible resources

Bible Tree

Yellow

To navigate through the Bible text

The easiest way to create a view is from the Window menu. There are also available shortcuts to do so.

The style of the colored caption can be changed from the View Menu (see below). You may even turn off completely the coloring of the captions, or even the captions themselves.

You can toggle the caption with or CTRL+F6 or by pressing on the button show_hide_captions on the main toolbar.

View Tabs

The Bible and Book Views have tabs or buttons that display an abbreviated name of a Bible or Book.  To view that particular resource, simply click the tab to display that resource.  This is the user's bookshelf so to speak, where all the titles can be seen and selected.

Manipulating Views - Active Views

Views can be created dynamically from the Window menu. You can have more than one views of each type visible at any time (except for the Bible Tree View).

theWord uses a unique way to indicate which is the Active view at any one time. Unlike other applications where there is only one active window, theWord has one active window per view type. This means, that if you have two Bible views open and three Book views, there is always one active Bible view and one active Book view. The active views are easily discerned because their captions are painted with a more intense color. Clicking on any view, will cause all other views of the same type to get 'deactivated' (their captions fade). Most operations in theWord that target a view occur on the currently active view. For example, if you use the Bible tree view to navigate to a verse, the active Bible view will be used to display the verse you selected. If you click on a link to display a topic from a commentary, then the active Book view will be used to display it.

TIP: At any time you want to execute an action whose result will be the display of some content in a view, you should first click on the desired view that you wish to be used and then perform the required action. Whenever you are in doubt "which view will be used if i do this", the short answer is "the active one", or "the one whose title is brighter than the others of the same type".

Try this: open two Bible Search views by clicking twice on menu Window -> New Bible Search View. Then, go to a Bible view, right click on a word and from the popup menu select the first option "Find [word]". Notice that the active Search View will be used to execute the search operation. If you want to make another search but keep the search results of this search query, just click on the second Bible Search View and repeat the operation: notice now that the second Bible Search View will be used. Notice also the titles of the two Bible Search views to see the difference in the color that indicates which one is the active.

Views can be easily manipulated within theWord.  Views are normally docked in some sort of layout, according to the user's wishes.  Views can also be detached from the main window to float.  This is done simply by clicking and dragging the title bar of the View (notice that the titles must be visible to do so, use CTRL+F6 to toggle the visibility of captions).  The View will move where you mouse moves. You can freely rearrange the views within the main window by dragging it to another place.

TIP: if you hold down the CTRL key while you drag a view, it will not get automatically docked in the main window (will remain floating). This allows you to move it freely over the main program window without worrying of it getting docked to an undesired place.

A View can be resized by holding down the mouse at the edge of it and dragging it (notice the mouse pointer changes to a double-edge arrow in that case to indicate the you can resize the View). As a view is resized, all other views in the main window are equally resized to fill in all available space of the main window.

Views can also be maximized.  This is done in two ways:

1.Double-clicking the View's title bar, or
2.Clicking the maximize button at the right side of the View's title bar.

To restore a maximized View, simply double-click the caption bar of the view or click the restore button (which is at the same place as the maximized button).  You cannot maximize a floating view. You cannot also maximize the Bible Tree View.

Creating new views - inheritance of options

You can create new views either from the Window menu, or by using the available shortcuts. The following table lists the shortcuts used:

 

Bible view

Bible Search view

Book view

Book search view

Create a new one

F11

F10

F12

F9

Create a new floating one

SHIFT+F11

SHIFT+F10

SHIFT+F12

SHIFT+F9

Navigate

CTRL+F11

CTRL+F10

CTRL+F12

CTRL+F9

Close view

CTRL+SHIFT+F11

CTRL+SHIFT+F10

CTRL+SHIFT+F12

CTRL+SHIFT+F9

Each view has a number of options that you can set in order to match your preferences.

There are always 2 ways to create a view:

either with the shortcuts above (or the menu Window), or
by clicking on the New Window button that exists in all view (e.g. for Bible view: clip0087, similar icons for other views)

Notice that there is a difference in the initial settings of the new view that depends on which way you created the view:

if you created the view from the menu Window (or the above shortcuts) then the new view will be initialized with the settings of the last view that you closed. So, if you just closed a Bible view window were you have customized with specific setting, clicking on F11 will recreate the exact same view.
If you use the New Window buttons on each view, then the new view will have the same settings as the view you clicked the button on (e.g. a duplicate of this view will be created). This is important to understand in order be able to easily duplicate the options of your views.

TIP: To see how options of each view are inherited to newly created views, do the following: open 2 Bible views and in one of them change the background color (this can be done from the menu Tools -> Bible view options, Fonts colors and styles category, Default background color setting). Now, click on one of these views and press F11 to create a new Bible view: notice that the new Bible view will have the same background color with the view you clicked on just before you pressed F11. Close this view (from the X button on the top-right of it's caption) and now click on the other Bible view and repeat. Notice that the new Bible view will now have the background color of the second Bible view.

Remember that all settings of the active view are inherited to a newly created view (for each view type). Moreover, remember that if you close all views of the same type, the last one you closed will be used as a template the next time you create a new view of the same type.

You can save and restore the entire set of views by using layouts.

View Menu

Below is the View Menu.  You can access it via the button shown.

View Menu

View Menu

The first option in this menu is obvious.

The second option allows the user to dock the View to the yellow areas shown. You can use this menu, instead of dragging a view with your mouse, if you find it difficult to place a view at the exact position you have in mind. As you hover over this menu, a shaded rectangle will appear on the main window indicating the place that this view will be docked.

Dock Menu

Dock Menu

The Caption Color menu allows the user to change the look of the title bars of the menus according to predefined schemes and select to show title bar icons for menu, maximize, and close.  Try them out to see which ones you like best.

The final option, Restrict floating windows within screen,  forces floating Views to stay within the monitor screen (in a multi monitor setup, you are still able to drag the floating views to a different monitor, yet they will always remain within the limits of the monitor).

Arrangement of Views

The different views can be arranged in theWord in the way the following diagram displays:

Views Arrangements

Views Arrangements

The gray thick-border rectangles display the pre-defined areas where views can be placed/docked. Notice for example that the top and bottom rows extend to the full width of the main window, unlike the left and right columns that will not extend to the full height, if there are views in the top/bottom rows.

The green thin-border rectangles display possible placement of views, and how they will be arranged in the pre-defined dock areas.

 
 
  theWord®
  ©2003-2012 Costas Stergiou
manual version: 4.0.1327