Searching for "Lord's" returns no hits

Have you found a bug or you think that the program does not function as expected? Report it here
NorrinRadd
Posts: 180
Joined: Fri Aug 13, 2010 10:12 am

Searching for "Lord's" returns no hits

Post by NorrinRadd »

I know the word occurs in *at least* one verse -- Rev. 1:10 -- but I don't find it in that verse or anywhere else via Search in any of the several translations I've tried (NET2, NIV2011, CEB, NASB2020, ISV2, NKJV, and more).
User avatar
JG
Posts: 4338
Joined: Wed Jun 04, 2008 8:34 pm

Re: Searching for "Lord's" returns no hits

Post by JG »

It is the case that publisher's can use a different coding for the "apostrophe" in Lord's (or anywhere for that matter.)
Since build 1513 this was fixed to account for this, but only when using the "ignore case and diacritics".
Otherwise you have to know the type of apostrophe used, or use a regular expression like Lord\p{P}s This is also case sensitive so you need to be specific.
which is case sensitive also.

1513: Search enhancement: when searching ignoring diacritics, the following characters are all considered equivalent:
- quotation mark u+0022 "
- apostrophe u+0027 '
- grave accent u+0060 `
- acute accent u+00b4 ´
- left single quotation mark u+2018
- right single quotation mark u+2019
- left double quotation mark u+201c
- right double quotation mark u+201d
Jon
the
Word 6 Bible Software
OS for testing; Windows 10
Beta Download ------Beta Setup Guide------On-line Manual------Tech doc's and Utilities------Copyright Factsheet
NorrinRadd
Posts: 180
Joined: Fri Aug 13, 2010 10:12 am

Re: Searching for "Lord's" returns no hits

Post by NorrinRadd »

Wow.

Ok, thanks.
Post Reply